Get in touch
Back
Maintenance

We are rolling out new features for our customers

Completed 30 Nov at 04:00pm CET.

Access to our dashboard Access to our API Access to Ad Hoc charging Access to Onboarding App
Completed

Maintenance completed

Posted 30 Nov at 04:00pm CET.
Started

As part of our constant effort to improve and enhance your reev experience, we are running a planned release of new and advanced features for our users. This can cause a momentary downtime of our charge points. For more information about the release, general questions & feedback, please feel free to contact us via support@reev.com. Thank you! Your reev team.

Posted 30 Nov at 02:00pm CET.