Get in touch
Back
Maintenance

Scheduled maintenance - we are updating our system!

Completed 24 May at 03:30pm CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 24 May at 03:30pm CEST.
Started

As part of our regular scheduled maintenance efforts, we are updating our system to improve the usability of our services. Some charge points will be briefly unavailable. If you want to learn more about our system updates or if you have any questions, concerns & feedback, please feel free to contact us via support@reev.com. Thank you! Your reev team.

Posted 24 May at 03:00pm CEST.