Back
Maintenance

Connectivity Issues for new Chargepoints
Completed 23 May at 03:05pm CEST.
ChargePoint connection
Completed
Maintenance completed
Posted
23 May at 03:05pm CEST.

Started
We are currently experiencing connection issues for new Chargepoints. The root cause is identified and will be resolved in a few minutes.
Posted
23 May at 01:00pm CEST.