Get in touch
Back
Degraded

Support availability degraded

Started 28 Mar at 01:15pm CEST, resolved 28 Mar at 03:54pm CEST.

Access to our homepage
Resolved

All support phone numbers are now available again and our support team is available as usual.

We apologize for the inconvenience that might have been caused.

Posted 28 Mar at 03:54pm CEST.
Created

The reev support phone availability is degraded at the moment. We are working on a solution with our provider.
Meanwhile you are able to reach the support team through support@reev.com or use the following phone number: +49 89 21538970

Posted 28 Mar at 01:15pm CEST.