Get in touch
Back
Maintenance

System Maintenance

Completed 3 Mar at 12:00pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 3 Mar at 12:00pm CET.
Started

We are upgrading all of our systems and services will be unavailable between 09:00 and 12:00

Posted 3 Mar at 09:00am CET.