Get in touch
Back
Maintenance

Release

Completed 26 Apr at 09:00pm CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 26 Apr at 09:00pm CEST.
Started

We are releasing a new version and systems will be briefly unavailable between 20:00 and 21:00 CEST.

Posted 26 Apr at 08:00pm CEST.