Get in touch
Back
Maintenance

Updating systems

Completed 8 Apr at 09:00pm CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 8 Apr at 09:00pm CEST.
Started

Releasing latest fixes and improvements

Posted 8 Apr at 08:30pm CEST.