Get in touch
Back
Maintenance

Regular Maintenance

Completed 11 Mar at 05:00am CET.

Access to our dashboard ChargePoint connection Access to our API Access to our homepage
Completed

Maintenance completed

Posted 11 Mar at 05:00am CET.
Started

Our systems couldn't be accessible during the maintenance time and access to the dashboard and Charge Point access may be briefly interrupted.

Posted 11 Mar at 12:00am CET.