Get in touch
Back
Maintenance

System maintenance

Completed 8 Feb at 10:00pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 8 Feb at 10:00pm CET.
Started

We are upgrading our services

Posted 8 Feb at 09:05pm CET.