Get in touch
Back
Maintenance

Release

Completed 9 Dec at 02:00am CET.

Access to our dashboard ChargePoint connection Access to our API Access to our homepage
Completed

Maintenance completed

Posted 9 Dec at 02:00am CET.
Started

Release Day - A new Version of our Backend and Dashboard is being deployed and access to dashboard and CP access may be briefly interrupted.

Posted 8 Dec at 11:00pm CET.