Get in touch
Back
Maintenance

Regular maintenance

Completed 15 Oct at 01:30am CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 15 Oct at 01:30am CEST.
Started

we are patching our systems between 00:30 and 01:30 CEST and services will be briefly unavailable.

Posted 15 Oct at 12:30am CEST.