Get in touch
Back
Maintenance

Regular maintenance

Completed 30 Sep at 09:30pm CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 30 Sep at 09:30pm CEST.
Started

standard maintenance of our backend. Access to api, CP connection and dashboard may be interrupted.

Posted 30 Sep at 08:30pm CEST.