Get in touch
Back
Maintenance

System maintenance

Completed 13 Aug at 05:30am CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 13 Aug at 05:30am CEST.
Started

We are upgrading all of our systems and services will be unavailable between 0:00 and 5:30.

Posted 13 Aug at 01:00am CEST.