Get in touch
Back
Maintenance

We are rolling out bug fix

Completed 29 Nov at 03:03pm CET.

Started

Fix is related to webhook and should not effect user experience

Posted 29 Nov at 03:03pm CET.
Completed

Maintenance completed

Posted 29 Nov at 03:03pm CET.