Get in touch
Back
Maintenance

Scheduled maintenance - we are updating our system!

Completed 18 Sep at 11:30am CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 18 Sep at 11:30am CEST.
Started

As part of our regular scheduled maintenance efforts, we are updating our system to improve the usability of our services. If you want to learn more about our system updates or if you have any questions, concerns & feedback, please feel free to contact us via support@reev.com. Thank you! Your reev team.

Posted 18 Sep at 10:30am CEST.