Get in touch
Back
Maintenance

We are rolling out bug fixes to our customers

Completed 4 Aug at 06:45pm CEST.

Access to our dashboard ChargePoint connection Access to our API Access to our homepage Access to Ad Hoc charging Access to Onboarding App
Completed

Maintenance completed

Posted 4 Aug at 06:45pm CEST.
Started

During the maintenance there is minimal service interference expected

Posted 4 Aug at 06:00pm CEST.