Get in touch
Back
Maintenance

Scheduled Maintenance

Completed 20 Feb at 11:45am CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 20 Feb at 11:45am CET.
Started

We are rolling out new features to our customers

Posted 20 Feb at 11:00am CET.