Get in touch
Back
Degraded

Email delivery issues

Started 31 Jan at 02:07pm CET, resolved 31 Jan at 04:09pm CET.

Access to our dashboard
Resolved

Email delivery is working again.

Thank you for your patience.

Thank you.

Your reev team.

Posted 31 Jan at 04:09pm CET.
Created

Email functionality is currently not working.

We have already identified a fix and are releasing it in the next hour.

We apologize for the inconvenience.

Thank you!

Your reev team.

Posted 31 Jan at 02:07pm CET.