Get in touch
Back
Maintenance

We are rolling out new features to our customers

Completed 10 Jan at 03:15pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 10 Jan at 03:15pm CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times

Posted 10 Jan at 02:30pm CET.