Get in touch
Back
Maintenance

Maintanance

Completed 22 Dec at 02:00pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Posted 22 Dec at 02:00pm CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times

Posted 22 Dec at 01:30pm CET.