Get in touch
Back
Maintenance

Maintenance

Completed 21 Dec at 10:45am CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Posted 21 Dec at 10:45am CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times

Posted 21 Dec at 10:15am CET.