Get in touch
Back
Downtime

reev.com not available at the moment

Started 9 Dec at 10:21am CET, resolved 9 Dec at 12:11pm CET.

Access to our homepage
Resolved

reev.com is now available again. We are sorry for any inconvenience that this issue might have caused.

Posted 9 Dec at 12:11pm CET.
Created

reev.com is unavailable at the moment. We are investigating the issue and will inform you here as soon as we have any updates.

Posted 9 Dec at 10:21am CET.