Get in touch
Back
Maintenance

We are rolling out new features to our customers

Completed 6 Dec at 11:30am CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 6 Dec at 11:30am CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times

Posted 6 Dec at 10:00am CET.