Get in touch
Back
Maintenance

We are rolling out new features to our customers

Completed 11 Nov at 04:10pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Posted 11 Nov at 04:10pm CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times.

Posted 11 Nov at 03:40pm CET.