Get in touch
Back
Maintenance

We are rolling out new features to our customers

Completed 4 Nov at 02:40pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 4 Nov at 02:40pm CET.
Started

During the maintenance Chargepoints can be temporary offline and/or re-connect multiple times

Posted 4 Nov at 02:10pm CET.