Get in touch
Back
Maintenance

Rolling out new Features

Completed 3 Nov at 10:00am CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Posted 3 Nov at 10:00am CET.
Started

We are rolling out new features to our customers

Posted 3 Nov at 09:01am CET.