Get in touch
Back
Maintenance

Maintenance update

Completed 27 Jul at 08:30pm CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Posted 27 Jul at 08:30pm CEST.
Started

We are upgrading all of our systems and services

Posted 27 Jul at 07:30pm CEST.