Get in touch
Back
Maintenance

Regular Maintenance

Completed 15 Jul at 06:30pm CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 15 Jul at 06:30pm CEST.
Started

We are upgrading all of our systems and services will be unavailable between 17:30 and 18:30.

Posted 15 Jul at 05:30pm CEST.