Get in touch
Back
Maintenance

Release

Completed 8 Jul at 06:00pm CEST.

ChargePoint connection
Completed

Posted 8 Jul at 06:00pm CEST.
Started

We are releasing a new version and charge point communication will be briefly unavailable between 17:00 and 18:00 CEST.

Posted 8 Jul at 05:00pm CEST.