Get in touch
Back
Maintenance

System Maintenance

Completed 15 Jul at 05:00am CEST.

ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 15 Jul at 05:00am CEST.
Started

Our partner is performing regular maintenance during this time and our system might be briefly unavailable.

Posted 15 Jul at 12:00am CEST.