Get in touch
Back
Maintenance

Charge Point Connection issues

Completed 19 May at 09:35am CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 19 May at 09:35am CEST.
Started

Currently, we have some connectivity issues for Charge Points, we are working on that. You can see some difficulties in accessing our dashboard.

Posted 19 May at 09:16am CEST.