Get in touch
Back
Maintenance

Upgrading systems

Completed 8 Apr at 08:30pm CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 8 Apr at 08:30pm CEST.
Started

Releasing latest changes and fixes

Posted 8 Apr at 08:00pm CEST.