Get in touch
Back
Maintenance

Rollout of Infrastructure

Completed 24 Mar at 08:15pm CET.

Access to our dashboard ChargePoint connection Access to our API Access to our homepage
Completed

Maintenance completed

Posted 24 Mar at 08:15pm CET.
Started

The services won't be available at that time

Posted 24 Mar at 06:50pm CET.