Get in touch
Back
Maintenance

Release

Completed 16 Nov at 10:00pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 16 Nov at 10:00pm CET.
Started

Release Day - A new Version of our Backend and Dashboard is being deployed and access to dashboard and CP access may be briefly interrupted.

Posted 16 Nov at 09:00pm CET.