Get in touch
Back
Maintenance

Release

Completed 15 Nov at 08:45pm CET.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 15 Nov at 08:45pm CET.
Started

Release Day - A new Version of our Backend and Dashboard is being deployed and access to dashboard and CP access may be briefly interrupted.

Posted 15 Nov at 08:15pm CET.