Get in touch
Back
Maintenance

Updates to Infrastructure

Completed 13 Oct at 01:00am CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 13 Oct at 01:00am CEST.
Started

Our external service provider announced regular maintenance:
https://status.mcon-group.info/

Posted 12 Oct at 08:00pm CEST.