Get in touch
Back
Maintenance

Release

Completed 26 Sep at 06:00pm CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 26 Sep at 06:00pm CEST.
Started

We are releasing some fixes and charge point communication will be briefly unavailable between 17:00 and 18:00 CEST.

Posted 26 Sep at 05:00pm CEST.