Get in touch
Back
Maintenance

Release

Completed 12 Sep at 05:30pm CEST.

ChargePoint connection
Started

We are releasing a new version and charge point communication will be briefly unavailable between 17:30 and 18:30 CEST.

Posted 12 Sep at 05:30pm CEST.
Completed

Maintenance completed

Posted 12 Sep at 05:30pm CEST.