Get in touch
Back
Maintenance

Deploying stability improvements

Completed 1 Sep at 07:30pm CEST.

ChargePoint connection
Completed

Maintenance completed

Posted 1 Sep at 07:30pm CEST.
Started

We are deploying stability improvements to handle increasing number of customers and chargepoints.
Chargepoints may experience a re-connect during this time.

Thanks & keep charging ⚡️🔋

Posted 1 Sep at 07:00pm CEST.