Get in touch
Back
Maintenance

Upgrading systems

Completed 30 Aug at 08:30pm CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 30 Aug at 08:30pm CEST.
Started

We are deploying new features and bugfixes

Posted 30 Aug at 07:30pm CEST.