Get in touch
Back
Maintenance

System Maintenance

Completed 12 Aug at 05:00am CEST.

Access to our dashboard ChargePoint connection Access to our API
Completed

Maintenance completed

Posted 12 Aug at 05:00am CEST.
Started

We are upgrading all of our systems and services will be unavailable between 0:00 and 5:00

Posted 12 Aug at 12:00am CEST.